[8.90.1] CoreELEC for S905/S912 devices

  • Just noticed a new devel build popped up today April l. Has anyone tried it yet and could comment? The Coolest   GDPR-1

    It has a fix for delayed video after audio starts. That's the only difference.


    Is this in the current dev build? Would it also work in downgrading to the 8.2 builds as well?

    Downgrading/Upgrading will work if installed to internal only with devel image


    If you are installed to external any image will be okay.


    Many certainly will appreciate if you would also add a support for an MXQ Pro OTT (S905) device. I tried the LE 9.0 (8.90.6) version from GDPR-2 + any gxbb_p200 DTB versions for an S905 platform and my MXQ Pro just boots to a debug message.

    Need more information...

  • Thanks a lot for your hard work GDPR-2

    Latest devel runs nice on Khadas Vim.

    Have to test pvr and audio. But at first boot it was great

    Edited once, last by tavoc ().

  • Hi adamg first of all thank for your great work for community, you are great devolper alive today. plz do something for S905x boxes because first line of srt subtitles are also stuttering in S905X and I notice some specific movies are also have stuttering because of srt subtitles. wrxtasy has fixed S912 boxes issues of subtitle stuttering, port some type of patch. Plz add wrxtasy’s patch in Your great 8.90.6 Build for S905X. It is request.

  • I don't know where wrxtasy publish his changes.

    GDPR-2

    For LE 8.9.x Leia - kszaq has already done the hard work for you, this PR:

    https://github.com/LibreELEC/LibreELEC.tv/pull/2512


    Make sure to add in the AML options file this for each S9xx device as appropriate:

    LibreELEC.tv/options at le90_amlogic_r7p0 · kszaq/LibreELEC.tv · GitHub


    And then also patch the Kernel with this PR:

    [3.14] Fix vsync for Mali r6p1 and later by kszaq · Pull Request #94 · LibreELEC/linux-amlogic · GitHub


    You may even find software decoded 720p Netflix will playback on S912's without stuttering. I have not tested that tho.

  • It has a fix for delayed video after audio starts. That's the only difference.


    Downgrading/Upgrading will work if installed to internal only with devel image


    If you are installed to external any image will be okay.

    Downgraded to 8.2.4 on external. Just wanted to report all worked fine.

  • I've got a feeling that the Easter bunny is about to lay a huge egg ;)

    -2re


    8.90 ⇒ MeCool KI Pro ⇒ Onkyo TX-NR656 ⇒ SAMSUNG 65"LED/UHD/PQ1300/T2CS

    LG BP50NB40 USB Blu-ray


  • I had installed 8.90.6 on minix u1 and all sorts of playback issues, went back to previous build and was fine. Now I have updated to the latest dev build and all the playback issues seem to have been sorted. The only thing I notice is that I can’t set my screen to 4K (inside libreelec) and 2160p files also don’t load, aside from that, it’s been v good.

  • I had installed 8.90.6 on minix u1 and all sorts of playback issues, went back to previous build and was fine. Now I have updated to the latest dev build and all the playback issues seem to have been sorted. The only thing I notice is that I can’t set my screen to 4K (inside libreelec) and 2160p files also don’t load, aside from that, it’s been v good.

    I'm running the latest dev, and I have no problems with 4k.

    -2re


    8.90 ⇒ MeCool KI Pro ⇒ Onkyo TX-NR656 ⇒ SAMSUNG 65"LED/UHD/PQ1300/T2CS

    LG BP50NB40 USB Blu-ray


  • it would be nice to also have a Netflix fix for 905.

    netflix works fine for me on s905x, primary reason I run LE9. Tried on latest dev build and 8.90.3. Max resolution is 720p due to SW decoding on LE.

  • Hi, I had the same issue. Fixed by editing /storage/.kodi/userdata/guisettings.xml replace 60 with 30

    Code
    1. service kodi stop
    2. vi /storage/.kodi/userdata/guisettings.xml
    3. ...
    4. <setting id="videoscreen.resolution">30</setting>
    5. <setting id="videoscreen.screen" default="true">0</setting>
    6. <setting id="videoscreen.screenmode">00384002160030.00000pstd</setting>
    7. ...


    Best regards

    Charlie.

    you seem to use another LE-version. the guisettings.xml on 8.90.6 does not contain these lines. there is also no command 'service', but 'systemctl'


    how can I set the GUI-refresh rate via ssh to a fixed value in 8.90.6?



    Box: Beelink Mini MXIII II (S905X/2GB/32GB SD)

    running: LE 8.2.3.1 (thanks kszaq ) and CE 8.90.0 (thanks adamg + afl1 )

  • you seem to use another LE-version. the guisettings.xml on 8.90.6 does not contain these lines. there is also no command 'service', but 'systemctl'


    how can I set the GUI-refresh rate via ssh to a fixed value in 8.90.6?

    Update to latest devel build and you will not need to do any of this.

  • Update to latest devel build and you will not need to do any of this.

    happy easter to you, GDPR-2 ! may the easter bunny gifted you with huge eggs.. :-)

    I will try the latest devel build tonight and report back, thanks a lot.



    Box: Beelink Mini MXIII II (S905X/2GB/32GB SD)

    running: LE 8.2.3.1 (thanks kszaq ) and CE 8.90.0 (thanks adamg + afl1 )

  • A short status on the last devel:

    AAC 2.0 problems seems to be fixed.

    Dobly Atmos failed to play 2 times, after stopping the video and starting it again, it worked fine. (i'll test some more.)

    Chroma upscaling is bad.

    Disabling deinterlacing makes streams/DVB play slowmo and/or jumpy. But chroma upscaling is good.


    Every thing else, Excellent ;)

    -2re


    8.90 ⇒ MeCool KI Pro ⇒ Onkyo TX-NR656 ⇒ SAMSUNG 65"LED/UHD/PQ1300/T2CS

    LG BP50NB40 USB Blu-ray