[8.90.1] CoreELEC for S905/S912 devices

  • I Think this has to do with your TV settings. Check your TV menu for Picture Size etc... :)

    -2re


    8.90 ⇒ MeCool KI Pro ⇒ Onkyo TX-NR656 ⇒ SAMSUNG 65"LED/UHD/PQ1300/T2CS

    LG BP50NB40 USB Blu-ray


  • I Think this has to do with your TV settings. Check your TV menu for Picture Size etc... :)

    But it also occurs if I restart the box without turning of the TV. I was thinking this would indicate the fault to be with the box. Is there any reason I should not trust the box telling it's correct refresh rate?


    Otherwise I will check the TV settings but they are unchanged since ever, but maybe some auto settings get something wrong...

  • But it also occurs if I restart the box without turning of the TV. I was thinking this would indicate the fault to be with the box. Is there any reason I should not trust the box telling it's correct refresh rate?


    Otherwise I will check the TV settings but they are unchanged since ever, but maybe some auto settings get something wrong...

    You should also check System->Display->Video calibration in Kodi. I think these settings are stored for each resolution/hz.

    -2re


    8.90 ⇒ MeCool KI Pro ⇒ Onkyo TX-NR656 ⇒ SAMSUNG 65"LED/UHD/PQ1300/T2CS

    LG BP50NB40 USB Blu-ray


  • You should also check System->Display->Video calibration in Kodi. I think these settings are stored for each resolution/hz.

    Thanks, I will. As I said, adjusting the screen for one refresh rate breaks the adjustment for the other refresh rate. I don't know if this is expected. If it is only me seeing it, it may be my TV.

  • Thanks, I will. As I said, adjusting the screen for one refresh rate breaks the adjustment for the other refresh rate. I don't know if this is expected. If it is only me seeing it, it may be my TV.

    System->Display->Video calibration in Kodi. ;)

    ps. Do this for all resolutions/hz settings.

    -2re


    8.90 ⇒ MeCool KI Pro ⇒ Onkyo TX-NR656 ⇒ SAMSUNG 65"LED/UHD/PQ1300/T2CS

    LG BP50NB40 USB Blu-ray


  • System->Display->Video calibration in Kodi. ;)

    ps. Do this for all resolutions/hz settings.

    This is what I mean by adjusting the screen. Did it for 50Hz and 60Hz, switching from one to the other afterwards results in a not fitting screen.


    Is it only me? Then I guess it is my Samsung TV...there is a "fit to screen" setting which is set to "auto"...

  • GDPR-2 this looks interesting 3.16 Lts kernel


    GitHub - hardkernel/linux at odroidc2-v3.16.y


    with gpu, video acceleration etc...

    I had a quick look, judging from some PR comments this looks to be based on old code.


    GDPR-2 Do you have a PayPal account? I would like to show my appreciation, just a small amount to buy you a big beer. :-)

    I have to be somewhat altruistic here and refuse I'm afraid, these releases are the culmination of a number of people's work and it would not be appropriate to accept a reward no matter how big or small, we get free hardware from vendors and that is sufficient in my eyes. I appreciate the offer though, thank you.


    I just tried todays dev built and I'm still getting the intermittent "black screen" for a couple of seconds.

    This isn't fixed yet and I haven't verified the problem yet, we are working on issues 1 by 1.

    GDPR-2 , please test this patch, it looks like this revert solves the problem above, tested on my S912 device

    reverted 1 string from this commit:

    [windowing][VideoPlayer] move renderer flush to VideoPlayer · xbmc/[email protected] · GitHub

    Thanks I will look into this and your PCM patch, it is on my to do list, there just isn't enough hours in the day sometimes.


    Is there a version of the devel for the S912 ?


    Shoog

    I will look into providing one


    Got a Nexbox A95X that was running 8.90.5 (it had been auto updating for months...)

    I noticed it hadn't auto updated so manually dumped the 8.90.6 into the update folder, updated OK, rebooted but box hung at initial flashscreen

    Anyway managed to get it back using the latest devel image, burn to sd card, paperclip trick, installtointernal so all good just confused as it why it went t!ts up... /shrug

    auto update is disabled temporarily due to the kernel change, upgrading from .5 to .6 is not possible if you are installed to internal.


    upgrading from .5 to the devel image is possible though.

    I will look into this.

  • This is what I mean by adjusting the screen. Did it for 50Hz and 60Hz, switching from one to the other afterwards results in a not fitting screen.


    Is it only me? Then I guess it is my Samsung TV...there is a "fit to screen" setting which is set to "auto"...

    I have a Samsung, and mine is set to 16:9 standard, and fit to screen = on (not auto).

    -2re


    8.90 ⇒ MeCool KI Pro ⇒ Onkyo TX-NR656 ⇒ SAMSUNG 65"LED/UHD/PQ1300/T2CS

    LG BP50NB40 USB Blu-ray


  • Try out the latest devel image for issue 1

    Did that and things went even worse: no video playback at all, only sound - clicking around, box is freezing after a few seconds.

    Going back to version 20180221 and everything is fine (except the three issues I described).

    Wondering that I am the only one with a S905W that has these massive problems.

  • Did that and things went even worse: no video playback at all, only sound - clicking around, box is freezing after a few seconds.

    Going back to version 20180221 and everything is fine (except the three issues I described).

    Wondering that I am the only one with a S905W that has these massive problems.

    Have you seen my reply here? LED (VFD) Displays in LibreELEC

    Please let me know if you got the display to work.


    Regarding the other issues. I can't comment on the DVD one, but that doesn't sound like a kernel related problem to me.

    I don't have tvheadend, as I have IPTV. I also have a S905W box, running the latest devel, and it seems to be working quite well.

    I'm not saying your issues are not real, but without a way to reproduce this, it becomes a matter of guesswork and trial and error to get things like this fixed. If you could record a short clip which reproduces the problem, it could help us find the problem and fix it.

  • I have a Samsung, and mine is set to 16:9 standard, and fit to screen = on (not auto).

    Just found that everything works as expected when changing the setting to "on" instead of "auto". Thanks! Sometimes it is worth questioning devices from that one would expect to work flawlessly.

  • Tried the latest dev build on my Minix Neo U1. Watched three different programs and the stuttering issue seems to have gone.

  • This isn't fixed yet and I haven't verified the problem yet, we are working on issues 1 by 1.

    Thanks, let me know if there's anything I can do to help!

    2xMinix U1, Onkyo NR626 and Samsung 40" 4K TV