[8.90.1] CoreELEC for S905/S912 devices

  • Please try and confirm. This is not the first time I'm using libreelec, I already know the toothpick method.

    don't leave today's commit for tomorrow:!:

  • Please try and confirm. This is not the first time I'm using libreelec, I already know the toothpick method.

    I will confirm later if it is the


    GDPR-2 :

    I know it is offtopic here but cannot find any info about your 8.2.4 versions.

    This was created mainly as a courtesy for users with a display on their device who did not want to use Leia alphas.

    It is based on kszaqs 8.2 branch with no modification other than what is stated in the CHANGELOG in the release directory


    If i wanted to build it myself do i use your master or libreelec-8.2 branch or libreelec.tv github amlogic branch?

    Neither because I do not always push the code for test releases immediately, if you want to build 8.90.6 then you would clone the master branch and then use 'git checkout 8.90.6'.

  • Neither because I do not always push the code for test releases immediately, if you want to build 8.90.6 then you would clone the master branch and then use 'git checkout 8.90.6'.

    Ah i see i did it 2 days ago to test how easy it was to build (didn't know if you were doing anymore community builds) and used libreelec-8.2 as it was the last branch with anything pushed, so I'm guessing this is useless then?

    w8AOi64.png

  • GDPR-2

    Just a note for you: Don't you agree, that adding 'with the right 8.2 dtb file (download link)' to your FAQ 'Can I downgrade back to 8.2?' would be necessary?

  • I tried with two usb and it does not boot. It does the reboot and stays in the libreelec screen. It does not happen from there.

  • A microsd card created with "LibreELEC-S905.arm-8.90.6.img.gz" is not being detected as a bootable media by KII Pro.
    Device simply boots into Android.
    Tried rufus, USB Image Tool, win32diskimager-binary... same result.

    Can somebody confirm that?

    I have the same problem on my X96, except that I have in internal 8.2.4.

    Not even 8.90.5 not works.

    Only 8.90.4. works OK.


    Reset button on X96 is not

  • GDPR-2

    Just a note for you: Don't you agree, that adding 'with the right 8.2 dtb file (download link)' to your FAQ 'Can I downgrade back to 8.2?' would be necessary?

    DTB upgrading and downgrading should happen automatically during the install process, it's not usually necessary to do anything extra other than copy the tar into the update folder and reboot.

  • After updating via tar file in update folder, my remote control wasn't working anymore (Alfawise H96 Pro+). But i also copied the dtb.img in upload folder, so maybe this caused the problem. I made a clean install via SD Card creator, copied the rc-config and remote control was working again.

  • Your device probably needs a rc keymap (it changed recently frome remote.conf to rc_maps.conf) I suggest that capable users with devices collect keymaps and we include those in the build so it's working ootb.

  • After updating via tar file in update folder, my remote control wasn't working anymore (Alfawise H96 Pro+). But i also copied the dtb.img in upload folder, so maybe this caused the problem. I made a clean install via SD Card creator, copied the rc-config and remote control was working again.

    Refer to the FAQ in post #3


    I tried with two usb and it does not boot. It does the reboot and stays in the libreelec screen. It does not happen from there.

    I can't help you if you don't even tell me which device you have...

  • I was wondering if anyone else has issues with hardware acceleration not being used.

    The first item I play is accelerated. Subsquent items are not, until I reboot it.

  • @Vinylity yes but I have disabled it at present


    After updating via tar file in update folder, my remote control wasn't working anymore (Alfawise H96 Pro+). But i also copied the dtb.img in upload folder, so maybe this caused the problem. I made a clean install via SD Card creator, copied the rc-config and remote control was working again.

    You should not copy DTB image when updating, there is no need to, the DTB is updated automatically, you will cause issues if you do this if there are future changes.

  • Thank you, i will try this with the next update nagain. Maybe i missunderstood the update instructions:

    Quote

    You should also download a new device tree, and put in Update folder with an update file. You should have both files in Update folder before rebooting. You do not need to rename device tree file before updating.

    BTW yesterday i had also big problems with LiveTV, audio out oft sync, sometimes stuttering video (VDR vnsi addon), but i see, there is already another thread here.