[8.90.1] CoreELEC for S905/S912 devices

  • CoreELEC 8.90 (Kodi Leia Alpha) for Amlogic S905/S912 devices.

    Read this first: [HOWTO + FAQ] Install community builds on S905/S905X/S912 device

    Important notes:

    • These are community supported builds so please post all bugs/issues in this forum area only.
    • These builds are experimental and based upon the LibreELEC master branch and as such should never be considered stable.
    • Bugs? Read this first: [READ FIRST] Reporting bugs

    If you forgot to use a new device tree or used wrong one and your device doesn't boot:

    • Don't panic!
    • if booting from SD/USB, simply connect SD/USB to your computer, download a proper device tree, rename it to dtb.img and place on SD/USB
    • if booting from internal:
      1. Boot this build from SD card or USB with correct device tree.
      2. Login over SSH and execute dd if=/dev/zero of=/dev/dtb bs=256k count=1 then dd if=/flash/dtb.img of=/dev/dtb bs=256k
      3. Power off, remove SD/USB, boot from internal.

    Downloads: here

    Choose .img.gz file for burning to a new USB drive or SD card and choose .tar if you are upgrading

    Known issues and important notes:

  • FAQ

    Q: Can I upgrade from 8.2 to this build?
    A: If you are installed on either an sdcard or usb drive then you should have no issues however if you are installed on internal you may encounter issues.

    Q: Can I downgrade back to 8.2?
    A: Refer to the above.

    Q: How do I update?

    A: Copy the tar file into the '.update' folder in /storage, DO NOT copy your DTB, this will be updated automatically, finally reboot.

    Q: Do these builds auto-update?

    A: Yes, you will receive a notification when an update is available, it will be downloaded automatically and applied on your next reboot.

    Q: My box has bricked when I have upgraded to this build.
    A: This is most probably a DTB issue, refer to post #1.

    Q: Amazon/Netflix addons do not work.

    A: These addons are dependant on inputstream.adaptive being installed and enabled and also libwidevinecdm.so being installed on your device.

    Q: Amazon/Netflix play poorly at 1080p.
    A: This is because the streams are being software decoded rather than hardware decoded, this will change as/if/when developers add support for it in Kodi upstream.

    Q: The display on my box doesn't work.
    A: Refer to the following thread

    Q: The display on my box shows the time but not the additional icons.
    A: Install FD628 addon from LE addons.

    Q: My remote doesn't work.

    A: Refer to the following thread.

  • Reporting bugs

    To report a bug or an issue with this build, please submit a ticket here for your issue if one does not exist already, you need to provide the following information:

    The type of your device (brand/model).

    CPU type. (S905/S905X/S905W/S912)

    RAM/Flash size.

    Resolution (1080p/4k).

    Refresh rate (24/25/30/50/60 Hz).

    Whether you are installed to internal or external.

    The exact version of the build used (the official build number or the devel number).

    The DTB file used (exact file name).

    Steps to reproduce the issue, whether it's add-on related, extra hardware (such as a DVB device), or any additional information you can provide.

    If you can provide demo files demonstrating the problem, that will be very useful.

    Failure to provide the above may result in your post being deleted.

  • This is the new thread for Leia community builds following on [8.90.6] LibreELEC 9.0 Alpha for S905/S912 devices from which had grown to almost 150 pages.

    General installation or help questions should be posted in their appropriate subforums as I will thoroughly moderate this thread and delete any posts that I feel are off topic.

    When reporting bugs if your post has no accompanying Kodi or kernel logs then your post may be deleted, if you are reporting an audio/visual bug then be sure to enable enable Verbose logging for the Audio and Video component.

  • There is an issue with start video for some channels and some video files: the picture appears several (3-6) seconds later after audio. (as was described in previous topic too)

    After some test I found that this issue appears only after refresh rate switching. If I set screen refresh rate the same as in video file than it starts without this issue.

    I hope it can help in something to find the reason.

    Also if you switch to SD channel (from HD or from SD channel) than you see black screen, last frame from previous channel and after this new channel started. There is no such issue if you switch from any channel to HD or UHD channel. I don't know if it's kodi or LE bug

  • Good to see the thread revived, all cleaned up ;)

    As mentioned before i'd like to confirm boot2k3 (and others) findings.


    (Only) in LiveTV, on changing channels, there's a black screen or picture freeze for about 5-8 seconds. Sound is sometimes audible, in cases where picture freezes, there's no sound during this time. After 5-8 seconds, image and sound catch up and stream is displayed.

    On HD Channels mostly, there's continuous sound cut-offs while picture remains stable after first start of the stream.

    Stream format / FPS seems to matter; see below for my exact reproduction actions.


    minimx s905 1Gb / 1Gb

    dtb: gxbb_p200_1G_1Gbit.dtb

    M8s Mini s905 2Gb / 100MB

    dtb: gxbb_p200_2G_100M.dtb


    - Installed LE. 8.90.6 version

    - Installed LiveTV Addon (DVBLogic 6.x)

    - Enabled Debug Logging

    - Start Live TV stream: HD - result: picture starts frozen for 5-8 seconds, then catches up and plays without issue

    - Change Channel - Next Channel: HD. Sometimes fast and without issue; sometimes the same symptoms as above

    - Change Channel - Next Channel: HD. Same

    - Change Channel - Next Channel: SD. Mostly picks up fine immediately, sometimes freezes like above.

    I attached the clean log.


    • 01_KODI.zip

      (257.47 kB, downloaded 40 times, last: )

    'You're like a child who wanders into the middle of a movie and wants to know -..' ~ Walter Sobchak (The Big Lebowski)

    Edited 4 times, last by atreyu ().

  • Greetings,

    Mate; you are almost the last Mohikan for us.

    We do not want to lose you.

    Thank you for everything.

    Best regards..

  • boot2k3   atreyu afl1 has submitted some pull requests recently that appear to improve some of the issues with the new kernel, I will try to get a test build up later.

    ozkaradag I hate what is happening just as much as you guys do and it pains me to see good people walk away.

  • Sounds great, will try the test build when it's ready and give feedback.

    'You're like a child who wanders into the middle of a movie and wants to know -..' ~ Walter Sobchak (The Big Lebowski)

  • GDPR-2 :

    I know it is offtopic here but cannot find any info about your 8.2.4 versions.

    RPI3 1GB, Z4 RK3368 1GB, MINI MX-G 2GB, Mini M8S II 2GB (coreelec.org 9.0.1), H96 Pro 3GB (coreelec.org 9.0.1), ODORID N2 2GB (coreelec.org 9.0.1), H/K AVR 161S, LG 60SJ810V

  • A microsd card created with "LibreELEC-S905.arm-8.90.6.img.gz" is not being detected as a bootable media by KII Pro.
    Device simply boots into Android.
    Tried rufus, USB Image Tool, win32diskimager-binary... same result.

    Can somebody confirm that?

    don't leave today's commit for tomorrow:!:

  • A microsd card created with "LibreELEC-S905.arm-8.90.6.img.gz" is not being detected as a bootable media by KII Pro.
    Device simply boots into Android.
    Tried rufus, USB Image Tool, win32diskimager-binary... same result.

    Can somebody confirm that?


    Dude, hold the hole in the bottom of the device when inserting and inserting the sd-card.

    It will be opened from LE.

    Best regards...