Hello,


I just got an ODROID C2 and wanted to try playing some my files.

When playing some files the do not seem to be able to play, specifically there is either no response on the first try to play the video (just the default loading animation) or on the second try (after pressing Esc to stop the loading circle) there is only sound and no video (black screen).

The files are MKV with H265.


The problem does not occur when I try to play the files using Kodi on my workstation. Other players like MPV or VLC also work without issue.

Also I checked the old 8.1 version on my ODROID-C2, the problem is present as well.

Which leads me believe the problem to be specific to LibreELEC (on ODROID C2).


I created a log, when trying to play one such file: 2018-06-22 13:11:52.412 T:4086914992 NOTICE: ------------------------------- - Pastebin.com


What I could find in the log were the following lines, which may help identify the problem:

Code
  1. ...
  2. 2019-03-16 22:05:27.212 T:3539100528 DEBUG: CVideoPlayerVideo - video decoder returned error
  3. ...
  4. 2019-03-16 22:05:46.154 T:3890393968 ERROR: CDVDVideoCodecAmlogic::Open - InstanceGuard locked
  5. 2019-03-16 22:05:46.155 T:3890393968 INFO: CVideoPlayerVideo::OpenStream - could not open video codec
  6. 2019-03-16 22:05:46.155 T:3539100528 DEBUG: CVideoPlayerVideo - CDVDMsg::GENERAL_PAUSE: 0
  7. ...


Here is the video mediainfo of one of the problematic files:


The difference I could find between working files and the ones that are not is the line of the format profile.

Working ones have "Main [email protected]@Main" and not-working ones "@[email protected]". So the first part is missing, maybe this is stumping Kodi?


Thanks in advance.