hi, i was using the Vectrex add-on successfully on my RPi3B (using LibreELEC 9.0.0 / Kodi18.0).

then one day ago i updated LibreELEC to 9.0.1 / Kodi 18.1.

now when i try to start a Vectrex game, Kodi crashes. in the 01_KODI.log i can't see any ERRORS. the log is interrupted - i marked it with .END OF LOG.

log, crash.log, kodi forum.

  • yes,

    1. i downgraded from 9.0.1 to 9.0.0 -> kodi crashes when starting vectrex game.

    2. downgraded on 9.0.0 the Vectrex add-on to 1.2.0.3.112 -> kodi crashes when starting vectrex game.

    3. downgraded/updated (there is only one version available) on 9.0.0 the libretro add-on -> vectrex game starts sucessfully. everything is fine there.

    4. ubgraded to 9.0.1 -> starting vectrex game crashes kodi again.

    i tried everything to get Vectrex working on 9.0.1... nothing.


    then i tried again to downgrade to 9.0.0 in the same way as before (steps 1,2,3), but then i didn't got vectrex back to live.

    (why ?!?!?!)


    upgraded tp 9.0.1 and downgraded to 9.0.0 again.

    then deinstalled vectrex add-on with its relationships (kept libretro).

    reinstalled vectrex add-on on 9.0.0 -> vectrex was working again.


    tried the same under 9.0.1 -> no success, kodi crashed.

    tried to reproduce the re-install-procedure, downgraded to 9.0.0 again... but this time it looks like vectrex is dead for ever.

    (what ?!?!?!)


    i tried everything to get vectrex back to work on 9.0.0... but nothing works anymore.



    this is a very strange behavior.



    now on all combinations vectrex is broken...

    LibreELEC 9.0.1, upgraded from 9.0.0

    Libretro Compatibinity 1.1.0.113

    GCE-Vectrex (vecx) 1.2.0.3.113


    LibreELEC 9.0.1, upgraded from 9.0.0

    Libretro Compatibinity 1.1.0.113

    GCE-Vectrex (vecx) 1.2.0.3.112


    LibreELEC 9.0.0, after downgrading from 9.0.1

    Libretro Compatibinity 1.1.0.113

    GCE-Vectrex (vecx) 1.2.0.3.112


    LibreELEC 9.0.0, after downgrading from 9.0.1

    Libretro Compatibinity 1.1.0.113

    GCE-Vectrex (vecx) 1.2.0.3.113



    i will see if i can find a spare SD card to make a fresh installation of 9.0.0 and 9.0.1 and see how vectrex behave there

  • ok, i made a fresh clean installation of

    LibreELEC 9.0.0 (LibreELEC-RPi2.arm-9.0.0.img.gz) and

    LibreELEC 9.0.1 (LibreELEC-RPi2.arm-9.0.1.img.gz) on a SD card, to see if i can get reproducable results...


    short story:

    on LibreELEC 9.0.1, Vectrex isn't usable at all, because kodi crash as soon vectrex is starting a game/rom.

    on LibreELEC 9.0.0, vectrex is working under very special conditions.


    long story:

    LibreELEC 9.0.1 (clean installation or upgrade from 9.0.0):

    GCE-Vectrex (vecx) version 1.2.0.3.113 is not working ->will crash kodi always.


    LibreELEC 9.0.1 (clean installation or upgrade from 9.0.0):

    GCE-Vectrex (vecx) version 1.2.0.3.112 is not working ->will crash kodi always.


    LibreELEC 9.0.0 (clean installation or downgrade from 9.0.1):

    GCE-Vectrex (vecx) version 1.2.0.3.113 is not working ->will crash kodi always.


    LibreELEC 9.0.0 (clean installation or downgrade from 9.0.1):

    GCE-Vectrex (vecx) version 1.2.0.3.112 is working (see below!).

    but as soon as LibreELEC 9.0.0 was rebooted, kodi crash again when starting a vectrex game/rom.


    to get vectrex work again after a reboot of LibreELEC 9.0.0, i have to

    update GCE-Vectrex (vecx) version 1.2.0.3.112 to GCE-Vectrex (vecx) version 1.2.0.3.113

    and just after that "update" GCE-Vectrex (vecx) version 1.2.0.3.113 back to GCE-Vectrex (vecx) version 1.2.0.3.112.


    or uninstall GCE-Vectrex (vecx) version 1.2.0.3.112 and after that install GCE-Vectrex (vecx) version 1.2.0.3.112 again.


    (without rebooting LibreELEC 9.0.0 !!!)


    immediately after that, i can start a vectrex game/rom without crashing kodi.

    but as soon as i reboot LibreELEC, vectrex is broken again (to recover i have to update/update or uninstall/install again).


    under LibreELEC 9.0.1 i can not do that to get vectrex to work. but when downgrading to LibreELEC 9.0.0, vectrex is able to work under the strange conditions described above.


    same behavior, when using a RPi2B instead of a RPi3B.


    any idea what is going wrong there?

    or is it only way too early to expect a relaiable working game add-on?